CVE-2026-33857: mod_proxy_ajp of Apache HTTP Server · Out-of-bounds Read Vulnerability
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium · fixed in 2.4.67 : update Apache HTTP Server when convenient.
Data as of 27 Oct 2026, 01:23 UTC
- Patch
- Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
AI-suggested
Upgrade Apache HTTP Server to version 2.4.67 or later, where this vulnerability is fixed. No other mitigation is indicated or required.
Description
An out-of-bounds read vulnerability exists in the mod_proxy_ajp module of Apache HTTP Server versions through 2.4.66. This flaw allows an attacker to read memory outside the intended buffer boundaries, potentially exposing sensitive information. The issue is fixed in Apache HTTP Server version 2.4.67, and users are advised to upgrade to this version to mitigate the vulnerability.