Skip to main content
VulnerabilityPublished

CVE-2026-33857: Apache HTTP Server · Out-of-bounds Read

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 2.4.67 : update Apache HTTP Server when convenient.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • <=2.4.66
Fixed in–

AI-suggested

Users should upgrade Apache HTTP Server to version 2.4.67, which contains the official fix for this vulnerability. No other mitigation steps are indicated by the vendor advisory.

Description

Out-of-bounds Read vulnerability in mod_proxy_ajp of Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

References

Community reviews

Loading reviews…