Skip to main content
CVE-2026-121413VulnerabilityPublished

Parse Server before 8.6.112 and 9.0.0 before 9.10.6-alpha.4 contains an authorization bypass in the session upgrade

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121413· Low 2.3

Not known to be exploited · CVSS 2.3 Low : upgrade to 9.10.6-alpha.4 when convenient.

Data as of 3 Nov 2026, 16:30 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CNA (VulnCheck)CVSS 3.13.1
Patch
Available – fixed in 9.10.6-alpha.4, 8.6.112
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade parse-server to 9.10.6-alpha.4; parse-server to 8.6.112; parse-server to 9.10.6-alpha.4 or 8.6.112.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.10.6-alpha.4
Fixed in
  • 9.10.6-alpha.4
parse-communityparse-serverAffected
  • <8.6.112
Fixed in
  • 8.6.112
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.0.0 <9.10.6-alpha.4
  • <8.6.112
Fixed in
  • 9.10.6-alpha.4
  • 8.6.112

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Parse Server versions 8.6.112 and later, and 9.10.6-alpha.4 and later. Users should upgrade to these versions to remediate the authorization bypass vulnerability. No other mitigation guidance is provided.

Description

Parse Server versions before 8.6.112 and 9.0.0 before 9.10.6-alpha.4 have an authorization bypass vulnerability in the session upgrade endpoint. This flaw allows attackers with a valid session token to create new sessions without proper permission checks, extending session validity even after logout.

References

Community reviews

Loading reviews…