SurrealDB from 3.1.0 before 3.3.0 contains an incorrect authorization vulnerability that allows record users to infer
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.3.0 when convenient.
Data as of 3 Nov 2026, 16:29 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.3 |
- Patch
- Available – fixed in 3.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade surrealdb to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| surrealdbsurrealdb | Affected
| Fixed in
|
crates.iosurrealdbpkg:cargo/surrealdbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict record user permissions carefully and monitor query patterns that could exploit this inference vulnerability.
Description
SurrealDB versions from 3.1.0 up to but not including 3.3.0 contain an authorization vulnerability that allows users with record access to infer values of restricted fields. This occurs because the query planner uses indexes on fields protected by restrictive SELECT permissions, enabling attackers to perform specific queries that reveal information about restricted data.