Skip to main content
CVE-2026-122301VulnerabilityPublished

Parse Server before 8.6.114 and 9.0.0 before 9.10.6-alpha.6 returns field values in object create responses to callers

Affects parse-serverSource GCVE Database

0
Compare
Authoritative record:CVE-2026-122301· Low 2.3

Not known to be exploited · CVSS 2.3 Low : upgrade to 9.10.6-alpha.6 or 8.6.114 when convenient.

Data as of 5 Nov 2026, 04:28 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CNA (VulnCheck)CVSS 3.13.1
Patch
Available – fixed in 9.10.6-alpha.6, 8.6.114
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade parse-server to 9.10.6-alpha.6 or 8.6.114.

Affected software

ProductAffectedFixed in
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • <8.6.114
  • >=9.0.0 <9.10.6-alpha.6
Fixed in
  • 8.6.114
  • 9.10.6-alpha.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Parse Server versions 8.6.114 and 9.10.6-alpha.6 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No other mitigation steps are indicated.

Description

Parse Server versions before 8.6.114 and 9.0.0 before 9.10.6-alpha.6 have an information disclosure vulnerability where object create responses include field values even if the caller lacks read access via class-level permissions or ACL. This allows attackers with create permissions to obtain sensitive values set by Cloud Code triggers, schema defaults, or class default ACLs.

References

Community reviews

Loading reviews…