Skip to main content
VulnerabilityPublished Updated

Parse server: Incorrect version tags linked to external repository

Affects parse-serverSource GCVE Database

0

CVSS 7.5 High : upgrade to 4.5.2 soon.

Data as of 2 Nov 2026, 19:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.2, 4.10.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade parse-server to 4.5.2; parse-server to 4.10.0.

Affected software

ProductAffectedFixed in
npmparse-serverAffected
  • >=4.0.0 <4.5.2
Fixed in
  • 4.5.2
npmparse-serverAffected
  • >=4.6.0 <4.10.0
Fixed in
  • 4.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Parse Server version 4.10.0, which contains the fix by removing the incorrect tags and ensuring only approved code is referenced. Alternatively, downgrade to version 4.5.2 to avoid affected versions. The incorrect tags have been deleted from the official repository, but users should verify and remove any local or forked references to these tags.

Description

Incorrect version tags were pushed to the Parse Server repository linking to a personal fork with unreviewed code. Although no official releases included these tags, dependencies could be defined to use them, potentially introducing unreviewed or insecure code. Bitnami also published an image based on one such incorrect tag. Users are advised to upgrade to version 4.10.0 or downgrade to 4.5.2 to avoid these issues.

References

Community reviews

Loading reviews…