CVE-2024-47183: Parse Server's custom object ID allows to acquire role privileges
Affects parseSource GCVE Database
Not known to be exploited : upgrade to 7.3.0 soon.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.3.0
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade parse to 7.3.0.
Patches and advisories
- github.com/parse-community/parse-server/commit/13ee52f0d19ef3a3524b3d79aea100e587eb3cfc (opens in a new tab)
- github.com/parse-community/parse-server/commit/1bfbccf9ee7ea77533b2b2aa7c4c69f3bd35e66f (opens in a new tab)
- github.com/parse-community/parse-server/pull/9317 (opens in a new tab)
- github.com/parse-community/parse-server/pull/9318 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiparsepkg:bitnami/parseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Parse Server to version 6.5.9 or later, or 7.3.0 or later, where this vulnerability is fixed. Disabling the allowCustomObjectId option if not required can also mitigate the risk.
Description
Parse Server versions prior to 7.3.0 with the option allowCustomObjectId set to true are vulnerable to a privilege escalation issue. An attacker who can create a new user can specify a custom object ID that allows them to acquire the privileges of a specific role. This vulnerability has been fixed in versions 6.5.9 and 7.3.0.
References
- github.com/parse-community/parse-server/commit/13ee52f0d19ef3a3524b3d79aea100e587eb3cfc (opens in a new tab)
- github.com/parse-community/parse-server/commit/1bfbccf9ee7ea77533b2b2aa7c4c69f3bd35e66f (opens in a new tab)
- github.com/parse-community/parse-server/pull/9317 (opens in a new tab)
- github.com/parse-community/parse-server/pull/9318 (opens in a new tab)
- github.com/parse-community/parse-server/security/advisories/GHSA-8xq9-g7ch-35hg (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-47183 (opens in a new tab)