Skip to main content
VulnerabilityPublished

CVE-2026-115207: patch security update

Affects patchSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115207· Medium 5.5

Not known to be exploited · CVSS 5.5 Medium : upgrade to 2.7.6-17.oe2203sp4 when convenient.

Data as of 29 Oct 2026, 10:49 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.15.5
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.6-17.oe2203sp4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade patch to 2.7.6-17.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4patchpkg:rpm/openEuler/patch&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <2.7.6-17.oe2203sp4
Fixed in
  • 2.7.6-17.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patch by upgrading GNU patch to version 2.7.6-17.oe2203sp4 or later. This version includes the fix that properly validates patch headers to prevent absolute file path exploitation. Until patched, avoid applying untrusted patch files, especially from unverified sources.

Description

A vulnerability in GNU patch allows an attacker to create arbitrary files outside the intended directory by using specially crafted patch files containing absolute paths. This occurs due to missing validation during automatic patch reversal, permitting absolute file paths in patch headers. The flaw can lead to arbitrary file creation with the permissions of the user applying the patch. A fix is available in version 2.7.6-17.oe2203sp4.

References

Community reviews

Loading reviews…