Skip to main content
CVE-2026-93328VulnerabilityPublished

cloud-storage source · Path Traversal and Missing Authorization

Source GCVE Database

0
Authoritative record:CVE-2026-93328· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.5.0 as a priority.

Data as of 26 Oct 2026, 16:30 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade MCP Toolbox for Databases (googleapis/mcp-toolbox) to 1.5.0.

Affected software

ProductAffectedFixed in
Google CloudMCP Toolbox for Databases (googleapis/mcp-toolbox)Affected
  • >=1.2.0 <1.5.0
Fixed in
  • 1.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A critical vulnerability (CVE-2026-93328) exists in Google Cloud MCP Toolbox for Databases versions 1.2.0 through 1.4.0. It involves path traversal and missing authorization in the cloud-storage source component, allowing unauthenticated remote attackers to exfiltrate host files to external Google Cloud Storage buckets and overwrite arbitrary local files via crafted parameters.

References

Community reviews

Loading reviews…