Skip to main content
CVE-2026-108357VulnerabilityPublished

phpoffice/phpspreadsheet · PhpSpreadsheet: XmlScanner Bypass via Double-Encoded unentity() TOCTOU Allows XXE and Denial of Service

Affects phpoffice/phpspreadsheetSource GCVE Database

0
Authoritative record:CVE-2026-108357· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 5.10.0 soon.

Data as of 27 Oct 2026, 16:28 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.10.0, 3.10.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade phpoffice/phpspreadsheet to 5.10.0; phpoffice/phpspreadsheet to 3.10.8.

Affected software

ProductAffectedFixed in
Packagistphpoffice/phpspreadsheetAffected
  • >=4.0.0 <5.10.0
Fixed in
  • 5.10.0
Packagistphpoffice/phpspreadsheetAffected
  • >=3.3.0 <3.10.8
Fixed in
  • 3.10.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in PhpSpreadsheet versions 3.10.8 and 5.10.0 that fixes this vulnerability. Users should upgrade to these or later versions to remediate the issue. No additional mitigations are required if the patch is applied.

Description

PhpSpreadsheet's XmlScanner performs two scans on XML content, each followed by an entity decoding callback that runs after pattern checks. This allows a double-encoded entity sequence to bypass detection of dangerous <!DOCTYPE declarations, enabling XML External Entity (XXE) injection and Denial of Service (DoS) via entity expansion. The vulnerability affects PhpSpreadsheet versions >=3.3.0 <3.10.8 and >=4.0.0 <5.10.0. It is exploitable for DoS on all PHP versions and for XXE/SSRF on PHP versions below 8.0 or when LIBXML_NOENT is used. Fixed in versions 3.10.8 and 5.10.0.

References

Community reviews

Loading reviews…