Skip to main content
VulnerabilityPublished

CVE-2026-108358: PhpSpreadsheet · XmlScanner Bypass via ISO-2022 Escape Sequences Allows XXE and Denial of Service

Affects phpoffice/phpspreadsheetSource GCVE Database

0
Authoritative record:CVE-2026-108358· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 5.10.0 soon.

Data as of 27 Oct 2026, 16:28 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.10.0, 3.10.8, 2.4.8 +2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Packagistphpoffice/phpspreadsheetAffected
  • >=4.0.0 <5.10.0
Fixed in
  • 5.10.0
Packagistphpoffice/phpspreadsheetAffected
  • >=3.3.0 <3.10.8
Fixed in
  • 3.10.8
Packagistphpoffice/phpspreadsheetAffected
  • >=2.2.0 <2.4.8
Fixed in
  • 2.4.8
Packagistphpoffice/phpspreadsheetAffected
  • >=2.0.0 <2.1.19
Fixed in
  • 2.1.19
Packagistphpoffice/phpspreadsheetAffected
  • <1.30.7
Fixed in
  • 1.30.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade PhpSpreadsheet to versions 5.10.0, 3.10.8, 2.4.8, 2.1.19, or 1.30.7 or later. Applying these official fixes will prevent the bypass of the XmlScanner and mitigate the XXE and DoS vulnerabilities. No other specific mitigations are indicated by the vendor advisory.

Description

PhpSpreadsheet versions prior to 5.10.0, 3.10.8, 2.4.8, 2.1.19, and 1.30.7 contain a vulnerability in the XmlScanner::scan() method. The scanner's regex pattern only accounts for NULL byte interleaving when detecting <!DOCTYPE declarations, but ISO-2022 escape sequences can bypass this detection. This allows malicious XLSX files with crafted XML to include DOCTYPE declarations that enable XML External Entity (XXE) attacks and Denial of Service (DoS) via quadratic entity expansion. The issue affects all PHP versions for DoS and PHP versions below 8.0 or when LIBXML_NOENT is used for XXE/SSRF. A fix is available in the stated versions.

References

Community reviews

Loading reviews…