Skip to main content
VulnerabilityPublished

CVE-2025-71359: picklescan versions before 0.0.29 fail to detect malicious pickle payloads that exploit

Affects picklescanSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 0.0.29 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.0.29
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade picklescan to 0.0.29.

Affected software

ProductAffectedFixed in
PyPIpicklescanpkg:pypi/picklescanOther threatsAffected
  • <0.0.29
Fixed in
  • 0.0.29

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid deserializing pickle data from untrusted or unauthenticated sources. Consider implementing additional application-level validation or sandboxing of deserialization operations to reduce risk.

Description

picklescan versions before 0.0.29 fail to detect malicious pickle payloads that exploit lib2to3.pgen2.grammar.Grammar.loads in the reduce method. This allows attackers to craft pickle files that evade detection and execute arbitrary code during deserialization with pickle.load(). The vulnerability is categorized as CWE-502 (Deserialization of Untrusted Data) and has a high severity rating.

References

Community reviews

Loading reviews…