Skip to main content
VulnerabilityPublished Updated

CVE-2026-25990: Pillow · From 10.3.0 to before 12.1.1, n out-of-bounds write may be triggered when loading a specially

Affects pillowSource GCVE Database

0
Authoritative record:CVE-2026-25990· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 11.3.0-1ubuntu1.1 soon.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.3.0-1ubuntu1.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu pillow package to 11.3.0-1ubuntu1.1.

Affected software

ProductAffectedFixed in
Ubuntu 25.10pillowpkg:deb/ubuntu/pillow?arch=source&distro=questingOther threatsAffected
  • <11.3.0-1ubuntu1.1
Fixed in
  • 11.3.0-1ubuntu1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Pillow is a Python imaging library. From 10.3.0 to before 12.1.1, n out-of-bounds write may be triggered when loading a specially crafted PSD image. This vulnerability is fixed in 12.1.1.

References

Community reviews

Loading reviews…