CVE-2026-14330: pipewire security update
Affects pipewireSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium : upgrade to 0.3.63-7.oe2403sp4 when convenient.
Data as of 29 Oct 2026, 10:47 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.3.63-7.oe2403sp4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pipewire to 0.3.63-7.oe2403sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP4pipewirepkg:rpm/openEuler/pipewire&distro=openEuler-24.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official security update by upgrading PipeWire to version 0.3.63-7.oe2403sp4 or later, which contains the fix for this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
PipeWire versions prior to 0.3.63-7.oe2403sp4 contain a vulnerability involving multiple unbounded alloca() calls in the PulseAudio protocol server. This flaw allows an attacker with limited permissions inside a sandboxed environment, such as Flatpak, to escape the sandbox by loading a malicious library via PipeWire's PulseAudio compatibility layer. Successful exploitation can lead to arbitrary code execution outside the sandbox and compromise of the user's system. A patch fixing this issue is available in version 0.3.63-7.oe2403sp4.