Poppler before 25.04.0 allows crafted input files to trigger out-of-bounds reads in the JBIG2Bitmap::combine function
Source GCVE Database
Not known to be exploited · CVSS 4.0 Medium : upgrade to 25.04.0 when convenient.
Data as of 30 Oct 2026, 01:28 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 4.0 |
|---|
- Patch
- Available – fixed in 25.04.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 5 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the Debian debian/poppler package to 25.04.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Debiandebian/popplerpkg:deb/debian/popplerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Poppler version 25.04.0 and later. Users should upgrade to version 25.04.0 or newer to remediate this vulnerability. No other mitigation or workaround is indicated in the provided data.
Description
A vulnerability in Poppler before version 25.04.0 allows crafted input files to cause out-of-bounds reads in the JBIG2Bitmap::combine function due to a misplaced isOk check. This flaw affects the JBIG2Stream.cc component and can lead to a denial of service or application instability.