Skip to main content
CVE-2025-32365VulnerabilityPublished Updated

CVE-2025-32365: freedesktop Poppler · Out-of-bounds Read

Affects freedesktop PopplerSource CVE Database V5

0

Not known to be exploited · CVSS 4.0 Medium : upgrade to 25.04.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.04.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade debian/poppler to 25.04.0.

Affected software

ProductAffectedFixed in
Debiandebian/popplerpkg:deb/debian/popplerOther threatsAffected
  • <25.04.0
Fixed in
  • 25.04.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-32365, European organizations should prioritize upgrading Poppler to version 25.04.0 or later once the patch is released, as this will contain the corrected isOk check and boundary validation. Until then, organizations should implement strict input validation and filtering of PDF files, especially those from untrusted sources, to reduce exposure to crafted malicious documents. Sandboxing PDF rendering processes can limit the impact of potential crashes and prevent broader system compromise. Monitoring logs for application crashes related to PDF processing can help detect exploitation attempts. Additionally, consider deploying application whitelisting and restricting local user permissions to minimize the risk of local exploitation. For environments where upgrading is delayed, isolating PDF processing services and using alternative PDF libraries with no known vulnerabilities may be prudent. Regular vulnerability scanning and patch management processes should be enforced to quickly address this and similar issues.

Description

Poppler before 25.04.0 allows crafted input files to trigger out-of-bounds reads in the JBIG2Bitmap::combine function in JBIG2Stream.cc because of a misplaced isOk check.

References

Community reviews

Loading reviews…