Skip to main content
VulnerabilityPublished

CVE-2026-93312: poppler security update

Affects popplerSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-93312· Medium 5.3

Public exploit available · CVSS 5.3 Medium : upgrade to 0.90.0-19.oe2203sp4 as a priority.

Data as of 4 Nov 2026, 16:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.90.0-19.oe2203sp4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade poppler to 0.90.0-19.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4popplerpkg:rpm/openEuler/poppler&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <0.90.0-19.oe2203sp4
Fixed in
  • 0.90.0-19.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and upgrading to Poppler version 26.08.0 or later is recommended to remediate these vulnerabilities. Applying the official patches identified by the vendor is advised to address these issues. No alternative mitigations or workarounds are indicated.

Description

Multiple vulnerabilities have been identified in Freedesktop Poppler version 26.07.0, a PDF rendering library. These include a null pointer dereference in JBIG2Stream::rewind, and integer overflows in JBIG2Stream::readCodeTableSeg and FoFiTrueType::mapCodeToGID. All vulnerabilities can be exploited remotely and have publicly available exploits. Upgrading to version 26.08.0 or later addresses these issues.

References

Community reviews

Loading reviews…