Skip to main content
VulnerabilityPublished

CVE-2026-93312: poppler security update

Affects popplerSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-93312· Medium 5.3

Public exploit available · CVSS 5.3 Medium : upgrade to 23.12.0-15.oe2403sp3 as a priority.

Data as of 4 Nov 2026, 16:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 23.12.0-15.oe2403sp3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade poppler to 23.12.0-15.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3popplerpkg:rpm/openEuler/poppler&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <23.12.0-15.oe2403sp3
Fixed in
  • 23.12.0-15.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Poppler version 26.08.0. It is strongly recommended to upgrade to this version or later to remediate these vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.

Description

Multiple vulnerabilities have been identified in Freedesktop Poppler version 26.07.0, a PDF rendering library. These include a null pointer dereference in JBIG2Stream::rewind, and integer overflows in JBIG2Stream::readCodeTableSeg and FoFiTrueType::mapCodeToGID functions. All vulnerabilities can be triggered remotely and have publicly disclosed exploits. Upgrading to version 26.08.0 or later is recommended to address these issues.

References

Community reviews

Loading reviews…