CVE-2026-105613: PostgreSQL Anonymizer's range-based dummy functions dont constraint the range size
Affects postgresql_anonymizerSource GCVE Database
Not known to be exploited · CVSS 4.7 Medium : upgrade to 3.3.0 when convenient.
Data as of 28 Oct 2026, 19:43 UTC
- Patch
- Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade dalibo/postgresql_anonymizer to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PostgreSQL Anonymizer to version 3.3.0 or later, where this vulnerability has been fixed. No other mitigation is indicated.
Description
PostgreSQL Anonymizer's range-based dummy functions do not limit the size of the range, allowing an attacker to exhaust backend memory and cause an out-of-memory (OOM) kill. This leads to a cluster-wide crash recovery. The issue is fixed in PostgreSQL Anonymizer version 3.3.0 and later.