Bundesamt für Sicherheit in der Informationstechnik psqlodbc · PostgreSQL ODBC Treiber: Mehrere Schwachstellen ermöglichen Manipulation von Daten
Affects Bundesamt für Sicherheit in der Informationstechnik psqlodbcSource GCVE Database
Not known to be exploited · CVSS 7.5 High.
Data as of 4 Nov 2026, 12:30 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 7.5 |
|---|
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubpostgresql-interfaces/psqlodbcpkg:github/postgresql-interfaces/psqlodbcOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 18.00.0006 of the PostgreSQL ODBC Driver is available. Users should upgrade to this version to remediate the vulnerabilities.
Description
Multiple vulnerabilities in the PostgreSQL ODBC Driver (psqlodbc) allow manipulation of data. These issues affect versions prior to 18.00.0006 and version 18.00.0006 itself. A fixed version 18.00.0006 is available to address these vulnerabilities.
References
- wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-4307.json (opens in a new tab)
- wid.cert-bund.de/portal/wid/securityadvisory?name=WID-SEC-2026-4307 (opens in a new tab)
- github.com/postgresql-interfaces/psqlodbc/security/advisories/GHSA-qhmr-5339-q33r (opens in a new tab)
- github.com/postgresql-interfaces/psqlodbc/security/advisories/GHSA-hfm6-qfx8-v4xq (opens in a new tab)