CVE-2025-53628: Prior to 0.20.1, cpp-httplib does not have a limit for a unique line, permitting an attacker to
Affects cpp-httplibSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.3 Medium · fixed in 0.20.1 : update cpp-httplib when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.20.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10cpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade cpp-httplib to version 0.20.1 or later, where this vulnerability is fixed. No other mitigation is indicated.
Description
cpp-httplib versions prior to 0.20.1 lack a limit on the length of a unique line, allowing an attacker to cause arbitrary memory allocation. This vulnerability has been fixed in version 0.20.1. It is related to CVE-2025-53629. The issue can lead to high impact on confidentiality, integrity, and availability.
References
- ubuntu.com/security/CVE-2025-53628 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-53628 (opens in a new tab)
- github.com/yhirose/cpp-httplib/commit/7b752106ac42bd5b907793950d9125a0972c8e8e (opens in a new tab)
- github.com/yhirose/cpp-httplib/security/advisories/GHSA-j6p8-779x-p5pw (opens in a new tab)
- github.com/yhirose/cpp-httplib/security/advisories/GHSA-qjmq-h3cc-qv6w (opens in a new tab)