Skip to main content
VulnerabilityPublished

CVE-2026-61789: Prior to 0.22.6, read-only SQL validation can be bypassed on the MySQL and MariaDB connectors

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-61789· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 0.22.6 when convenient.

Data as of 30 Oct 2026, 20:18 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.06.1
Patch
Available – fixed in 0.22.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade dbhub to 0.22.6.

Affected software

ProductAffectedFixed in
bytebasedbhubAffected
  • <0.22.6
Fixed in
  • 0.22.6

AI-suggested

Upgrade DBHub to version 0.22.6 or later, where this vulnerability is fixed. No other mitigation is indicated or required.

Description

A vulnerability in DBHub prior to version 0.22.6 allows bypassing read-only SQL validation on the MySQL and MariaDB connectors. This occurs due to incorrect parsing of double-dash comments in SQL statements, enabling an attacker to hide write or destructive commands from validation. The issue does not affect PostgreSQL. The vulnerability is fixed in version 0.22.6.

References

Community reviews

Loading reviews…