Skip to main content
VulnerabilityPublished Updated

CVE-2025-25291: Ruby SAML allows a SAML authentication bypass due to DOCTYPE handling (parser differential)

Affects ruby-samlSource GCVE Database

0
Compare
Authoritative record:CVE-2025-25291· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.12.4 as a priority.

Data as of 30 Oct 2026, 01:18 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.09.3
Patch
Available – fixed in 1.12.4, 1.18.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade ruby-saml to 1.12.4; ruby-saml to 1.18.0.

Affected software

ProductAffectedFixed in
RubyGemsruby-samlAffected
  • <1.12.4
Fixed in
  • 1.12.4
RubyGemsruby-samlAffected
  • >=1.13.0 <1.18.0
Fixed in
  • 1.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading ruby-saml to version 1.12.4 or later, or to version 1.18.0 or later, as these versions contain fixes for the vulnerability. No other mitigation is indicated by the vendor advisory.

Description

A critical authentication bypass vulnerability exists in ruby-saml due to differences in XML parsing between ReXML and Nokogiri. This parser differential allows attackers to perform a Signature Wrapping attack, potentially bypassing authentication mechanisms. The vulnerability affects ruby-saml versions prior to 1.12.4 and versions from 1.13.0 up to but not including 1.18.0. Fixed versions 1.12.4 and 1.18.0 address this issue.

References

Community reviews

Loading reviews…