Skip to main content
CVE-2026-41079VulnerabilityPublished Updated

Prior to 2.4.17, a network-adjacent attacker can send a crafted SNMP response to the CUPS SNMP backend that causes an

Affects cupsSource GCVE Database

0
Authoritative record:CVE-2026-41079· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium · fixed in 2.4.1op1-1ubuntu4.20 : update cups when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.1op1-1ubuntu4.20, 2.4.7-1.2ubuntu7.13, 2.4.12-0ubuntu3.9 +1
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTScupspkg:deb/ubuntu/cups?arch=source&distro=resoluteOther threatsAffected
  • <2.4.16-1ubuntu1.2
Fixed in
  • 2.4.16-1ubuntu1.2
Ubuntu 25.10cupspkg:deb/ubuntu/cups?arch=source&distro=questingOther threatsAffected
  • <2.4.12-0ubuntu3.9
Fixed in
  • 2.4.12-0ubuntu3.9
Ubuntu 24.04 LTScupspkg:deb/ubuntu/cups?arch=source&distro=nobleOther threatsAffected
  • <2.4.7-1.2ubuntu7.13
Fixed in
  • 2.4.7-1.2ubuntu7.13
Ubuntu 22.04 LTScupspkg:deb/ubuntu/cups?arch=source&distro=jammyOther threatsAffected
  • <2.4.1op1-1ubuntu4.20
Fixed in
  • 2.4.1op1-1ubuntu4.20
Ubuntu Pro 20.04 LTScupspkg:deb/ubuntu/cups?arch=source&distro=esm-infra/focalOther threatsAffected
  • 2.2.12-2ubuntu1 – 2.3.1-9ubuntu1.9+esm4
21 affected builds
Fixed in–
Ubuntu Pro 18.04 LTScupspkg:deb/ubuntu/cups?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 2.2.4-7ubuntu2 – 2.2.7-1ubuntu2.10+esm10
27 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to 2.4.17, a network-adjacent attacker can send a crafted SNMP response to the CUPS SNMP backend that causes an out-of-bounds read of up to 176 bytes past a stack buffer. The leaked memory is converted from UTF-16 to UTF-8 and stored as printer supply description strings, which are subsequently visible to authenticated users via IPP Get-Printer-Attributes responses and the CUPS web interface. This vulnerability is fixed in 2.4.17.

References

Community reviews

Loading reviews…