Skip to main content
CVE-2026-115775VulnerabilityPublished Updated

Prior to 26.10.0rc1, the twisted.words.xish.domish ExpatElementStream parser allows an unauthenticated remote peer to

Affects twistedSource GCVE Database

0
Authoritative record:CVE-2026-115775· High 8.7

Not known to be exploited · CVSS 8.7 High · fixed in 26.10.0 : patch twisted soon.

Data as of 28 Oct 2026, 22:44 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 26.10.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10twistedpkg:deb/ubuntu/twisted?arch=source&distro=stonkingOther threatsAffected
  • =25.5.0-5
  • =26.4.0-4
Fixed in–
Ubuntu 26.04 LTStwistedpkg:deb/ubuntu/twisted?arch=source&distro=resoluteOther threatsAffected
  • 24.11.0-1 – 25.5.0-5ubuntu0.1
4 affected builds
Fixed in–
Ubuntu 24.04 LTStwistedpkg:deb/ubuntu/twisted?arch=source&distro=nobleOther threatsAffected
  • 22.4.0-4 – 24.3.0-1ubuntu0.2
6 affected builds
Fixed in–
Ubuntu 22.04 LTStwistedpkg:deb/ubuntu/twisted?arch=source&distro=jammyOther threatsAffected
  • 20.3.0-7ubuntu1 – 22.1.0-2ubuntu2.7
9 affected builds
Fixed in–
Ubuntu 20.04 LTStwistedpkg:deb/ubuntu/twisted?arch=source&distro=focalOther threatsAffected
  • 18.9.0-3ubuntu1 – 18.9.0-11ubuntu0.20.04.5
12 affected builds
Fixed in–
Ubuntu Pro 18.04 LTStwistedpkg:deb/ubuntu/twisted?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 16.6.0-2ubuntu3 – 17.9.0-2ubuntu0.3+esm2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to twisted version 26.10.0rc1 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

A vulnerability in the twisted.words.xish.domish ExpatElementStream parser prior to version 26.10.0rc1 allows an unauthenticated remote peer to exhaust server memory by keeping a container element open and continuously adding child elements. This occurs during XMPP pre-authentication stream parsing before credentials are accepted. The issue is fixed in version 26.10.0rc1.

References

Community reviews

Loading reviews…