Skip to main content
VulnerabilityPublished Updated

CVE-2026-39892: Prowler · Cryptography vulnerable to buffer overflow if non-contiguous buffers were passed to APIs

Affects prowlerSource GCVE Database

0
Compare
Authoritative record:CVE-2026-39892· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 5.26.0 when convenient.

Data as of 5 Nov 2026, 20:05 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (GitHub_M)CVSS 4.06.9
ADP (redhat-SADP)CVSS 3.17.3
Patch
Available – fixed in 5.26.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade prowler to 5.26.0.

Affected software

ProductAffectedFixed in
Homebrewprowlerpkg:brew/prowlerOther threatsAffected
  • >=5.23.0 <5.26.0
Fixed in
  • 5.26.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Prowler to version 5.26.0 or later, where this buffer overflow vulnerability is fixed. Red Hat has released multiple advisories with patches and updated container images. Applying these official fixes is the recommended remediation. No alternative mitigations or workarounds are indicated in the vendor advisories.

Description

A critical buffer overflow vulnerability (CVE-2026-39892) exists in Prowler versions 5.23.0 through 5.25.x when non-contiguous Python buffers are passed to certain cryptographic APIs such as Hash.update(). This flaw can cause reads past the end of the buffer on Python versions greater than 3.11. The vulnerability has a CVSS score of 9.8 and is fixed in version 5.26.0.

References

Community reviews

Loading reviews…