CVE-2024-45614: Puma's header normalization allows for client to clobber proxy set headers
Affects pumaSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 5.6.9 when convenient.
Data as of 31 Oct 2026, 01:25 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.4 |
|---|
- Patch
- Available – fixed in 5.6.9, 6.4.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade puma to 5.6.9; puma to 6.4.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemspuma | Affected
| Fixed in
|
| RubyGemspuma | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Puma to version 5.6.9 or later, or 6.4.3 or later, where the vulnerability is fixed by discarding underscore headers when the non-underscore version exists. As a workaround, configure proxies such as Nginx to reject headers containing underscores using the 'underscores_in_headers' setting. Users should immediately stop trusting proxy-set headers if they have not yet applied the patch.
Description
CVE-2024-45614 is a vulnerability in Puma's header normalization that allows clients to override headers set by intermediate proxies by using underscore variants of header names. This can affect users who trust proxy-set headers, potentially enabling attackers to downgrade connections to HTTP or redirect responses, risking confidentiality if combined with a MITM attack. Fixed versions 5.6.9 and 6.4.3 discard underscore headers when the non-underscore version exists. Users relying on proxy headers for security should upgrade immediately or configure proxies like Nginx to discard underscore headers.
References
- github.com/puma/puma/security/advisories/GHSA-9hf4-67fc-4vf4 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-45614 (opens in a new tab)
- github.com/puma/puma/commit/cac3fd18cf29ed43719ff5d52d9cfec215f0a043 (opens in a new tab)
- github.com/puma/puma/commit/f196b23be24712fb8fb16051cc124798cc84f70e (opens in a new tab)
- github.com/puma/puma (opens in a new tab)
- github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2024-45614.yml (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/11/msg00004.html (opens in a new tab)
- nginx.org/en/docs/http/ngx_http_core_module.html (opens in a new tab)