Skip to main content
CVE-2026-55206VulnerabilityPublished

Py7zr: Prior to 1.1.3, PackInfo._read()

Affects py7zrSource GCVE Database

0
Authoritative record:CVE-2026-55206· High 8.7

Not known to be exploited · CVSS 8.7 High · fixed in 1.1.3 : patch py7zr soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10py7zrpkg:deb/ubuntu/py7zr?arch=source&distro=stonkingOther threatsAffected
  • =1.1.2+dfsg-1
  • =1.1.2-1+really1.1.0+dfsg-2
  • =1.1.3+dfsg-1
Fixed in–
Ubuntu 26.04 LTSpy7zrpkg:deb/ubuntu/py7zr?arch=source&distro=resoluteOther threatsAffected
  • 1.0.0+dfsg1-1 – 1.1.2+dfsg-1
5 affected builds
Fixed in–
Ubuntu 25.10py7zrpkg:deb/ubuntu/py7zr?arch=source&distro=questingOther threatsAffected
  • =0.22.0+dfsg-1
  • =1.0.0+dfsg1-1
Fixed in–
Ubuntu 24.04 LTSpy7zrpkg:deb/ubuntu/py7zr?arch=source&distro=nobleOther threatsAffected
  • 0.11.3+dfsg-6 – 0.11.3+dfsg-8build1
4 affected builds
Fixed in–
Ubuntu 22.04 LTSpy7zrpkg:deb/ubuntu/py7zr?arch=source&distro=jammyOther threatsAffected
  • 0.11.3+dfsg-1 – 0.11.3+dfsg-4ubuntu0.1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Py7zr to version 1.1.3 or later, where this vulnerability is fixed. No other mitigation is indicated or required.

Description

Py7zr versions prior to 1.1.3 have a vulnerability in the PackInfo._read() function where an inefficient O(n^2) algorithm can cause excessive CPU consumption when processing crafted .7z archives. This can lead to denial of service by resource exhaustion during archive initialization. The issue is fixed in version 1.1.3.

References

Community reviews

Loading reviews…