Skip to main content
VulnerabilityPublished

CVE-2026-119197: pyasn1 has quadratic-complexity denial of service

Affects pyasn1Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119197· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 0.6.5 soon.

Data as of 31 Oct 2026, 01:55 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 0.6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pyasn1 to 0.6.5.

Affected software

ProductAffectedFixed in
PyPIpyasn1Affected
  • <0.6.5
Fixed in
  • 0.6.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pyasn1 to version 0.6.5 or later, which contains the fix for this vulnerability. Until upgrading, applications should reject or strictly limit ASN.1 inputs containing REAL values, especially those with large mantissas, before passing them to pyasn1 decoders. The appropriate input size limits depend on the application's CPU availability and expected request volume.

Description

pyasn1 versions 0.6.4 and earlier contain a denial of service vulnerability due to quadratic time complexity in decoding binary-encoded ASN.1 REAL values with large mantissas. This issue affects BER, CER, and DER decoders that use the vulnerable RealPayloadDecoder. An attacker supplying crafted ASN.1 data with large REAL mantissas can cause excessive CPU consumption during decoding. The vulnerability is fixed in pyasn1 version 0.6.5.

References

Community reviews

Loading reviews…