CVE-2026-119196: pyasn1 has quadratic CPU consumption
Affects pyasn1Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 0.6.5 soon.
Data as of 31 Oct 2026, 01:54 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 0.6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pyasn1 to 0.6.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIpyasn1 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 0.6.5 of pyasn1 is available that addresses this vulnerability. Users should upgrade to pyasn1 version 0.6.5 or later to remediate this issue. No additional mitigations are required if the upgrade is applied. If upgrading is not immediately possible, applications should implement input size and fragment count limits on ASN.1 data before decoding to reduce risk.
Description
pyasn1 versions up to 0.6.4 have a vulnerability in decoding constructed BIT STRING values where CPU consumption grows quadratically with input size. This occurs because the decoder repeatedly shifts and copies accumulated data for each fragment, leading to potential CPU exhaustion and denial of service when processing attacker-controlled ASN.1 data. The issue affects BER and CER decoders and certain schema-driven DER decoding paths. The vulnerability is fixed in version 0.6.5.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-2qm8-x737-gmw5 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119196 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/73ba7b043cc7e92cb37f16f2c955bff93b0e6f6c (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)