Skip to main content
VulnerabilityPublished Updated

CVE-2026-30922: pyasn1 is a generic ASN.1 library for Python

Affects pyasn1Source GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.5 High · fixed in 0.1.7-1ubuntu2.1+esm1 : patch pyasn1 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.7-1ubuntu2.1+esm1, 0.1.9-1ubuntu0.1~esm1, 0.4.2-3ubuntu0.18.04.1~esm1 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10pyasn1pkg:deb/ubuntu/pyasn1?arch=source&distro=questingOther threatsAffected
  • <0.6.1-1ubuntu0.2
Fixed in
  • 0.6.1-1ubuntu0.2
Ubuntu 24.04 LTSpyasn1pkg:deb/ubuntu/pyasn1?arch=source&distro=nobleOther threatsAffected
  • <0.4.8-4ubuntu0.2
Fixed in
  • 0.4.8-4ubuntu0.2
Ubuntu 22.04 LTSpyasn1pkg:deb/ubuntu/pyasn1?arch=source&distro=jammyOther threatsAffected
  • <0.4.8-1ubuntu0.2
Fixed in
  • 0.4.8-1ubuntu0.2
Ubuntu Pro 20.04 LTSpyasn1pkg:deb/ubuntu/pyasn1?arch=source&distro=esm-infra/focalOther threatsAffected
  • <0.4.2-3ubuntu0.20.04.1~esm1
Fixed in
  • 0.4.2-3ubuntu0.20.04.1~esm1
Ubuntu Pro 18.04 LTSpyasn1pkg:deb/ubuntu/pyasn1?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <0.4.2-3ubuntu0.18.04.1~esm1
Fixed in
  • 0.4.2-3ubuntu0.18.04.1~esm1
Ubuntu Pro 16.04 LTSpyasn1pkg:deb/ubuntu/pyasn1?arch=source&distro=esm-infra/xenialOther threatsAffected
  • <0.1.9-1ubuntu0.1~esm1
Fixed in
  • 0.1.9-1ubuntu0.1~esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.3, the `pyasn1` library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deeply nested structures. An attacker can supply a crafted payload containing thousands of nested `SEQUENCE` (`0x30`) or `SET` (`0x31`) tags with "Indefinite Length" (`0x80`) markers. This forces the decoder to recursively call itself until the Python interpreter crashes with a `RecursionError` or consumes all available memory (OOM), crashing the host application. This is a distinct vulnerability from CVE-2026-23490 (which addressed integer overflows in OID decoding). The fix for CVE-2026-23490 (`MAX_OID_ARC_CONTINUATION_OCTETS`) does not mitigate this recursion issue. Version 0.6.3 fixes this specific issue.

References

Community reviews

Loading reviews…