Skip to main content
VulnerabilityPublished Updated

CVE-2026-23490: Gcalcli · pyasn1 has a DoS vulnerability in decoder

Affects gcalcliSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.5.1_7 soon.

Data as of 1 Nov 2026, 01:38 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.1_7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade gcalcli to 4.5.1_7.

Affected software

ProductAffectedFixed in
Homebrewgcalclipkg:brew/gcalcliOther threatsAffected
  • >=4.5.0 <4.5.1_7
Fixed in
  • 4.5.1_7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to update pyasn1 to the fixed version 4.5.1_7 or later. The vendor advisory from Red Hat confirms the availability of an official fix. Users should upgrade to the patched version to prevent denial-of-service conditions caused by malformed RELATIVE-OID values. No additional mitigation steps are indicated by the vendor advisory.

Description

A denial-of-service (DoS) vulnerability exists in pyasn1 version 0.6.1 used by gcalcli, caused by memory exhaustion from malformed RELATIVE-OID values with excessive continuation octets during decoding. This flaw can cause affected applications to hang or crash due to resource exhaustion. The vulnerability affects versions >=4.5.0 and <4.5.1_7 of gcalcli. A fix is available in version 4.5.1_7. The issue may impact systems that decode ASN.1 data such as LDAP servers, TLS/SSL endpoints, and OCSP responders.

References

Community reviews

Loading reviews…