CVE-2026-59885: pyasn1 · Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service
Affects gcalcliSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 4.5.1_13 soon.
Data as of 1 Nov 2026, 01:38 UTC
- Patch
- Available – fixed in 4.5.1_13
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade gcalcli to 4.5.1_13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewgcalclipkg:brew/gcalcliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in pyasn1 version 0.6.4 that fixes the quadratic complexity issue by implementing linear-time arc accumulation. Users should upgrade to version 0.6.4 or later. As a workaround, limit the size of untrusted ASN.1 input before decoding to reduce risk of denial of service.
Description
CVE-2026-59885 is a denial of service vulnerability in the pyasn1 library affecting the BER/CER/DER decoders and encoders for OBJECT IDENTIFIER and RELATIVE-OID values. The flaw causes quadratic time complexity relative to the number of arcs, allowing a crafted payload with many arcs to consume excessive CPU and cause service disruption. This affects applications decoding untrusted ASN.1 data such as certificates, LDAP, SNMP, and Kerberos. The issue is fixed in pyasn1 version 0.6.4.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-8ppf-4f7h-5ppj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59885 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/45bdb19eb7df4b3780fe9c912c63e99bffc39dd9 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)