Skip to main content
VulnerabilityPublished Updated

CVE-2026-30922: Gcalcli · Denial of Service in pyasn1 via Unbounded Recursion

Affects gcalcliSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.5.1_9 soon.

Data as of 1 Nov 2026, 01:38 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.1_9
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade gcalcli to 4.5.1_9.

Affected software

ProductAffectedFixed in
Homebrewgcalclipkg:brew/gcalcliOther threatsAffected
  • >=4.3.0 <4.5.1_9
Fixed in
  • 4.5.1_9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in pyasn1 version 4.5.1_9. Users should upgrade to this fixed version to remediate the vulnerability. No additional mitigations are required if the patch is applied. Until patched, avoid parsing untrusted ASN.1 data or implement external limits on recursion depth if possible.

Description

The pyasn1 library used by gcalcli is vulnerable to a Denial of Service (DoS) caused by unbounded recursion when decoding ASN.1 data with deeply nested indefinite-length SEQUENCE or SET tags. An attacker can supply a crafted payload that triggers recursive decoding calls without depth checks, leading to a RecursionError or memory exhaustion, crashing the host application. This affects versions >=4.3.0 and <4.5.1_9. A fix is available in version 4.5.1_9.

References

Community reviews

Loading reviews…