CVE-2026-59884: Gcalcli · pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs
Affects gcalcliSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.5.1_13 soon.
Data as of 1 Nov 2026, 01:38 UTC
- Patch
- Available – fixed in 4.5.1_13
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade gcalcli to 4.5.1_13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewgcalclipkg:brew/gcalcliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in gcalcli version 4.5.1_13 which includes pyasn1 version 0.6.4 with the fix. Users should upgrade to this version or later. As a workaround, limit the size of untrusted inputs passed to the decode() function to prevent excessive resource consumption. No other mitigations are indicated.
Description
A denial of service vulnerability exists in the pyasn1 BER/CER/DER decoder used by gcalcli, caused by unbounded long-form tag IDs that lead to excessive CPU consumption. The flaw allows crafted inputs to force the decoder to build very large integers, causing quadratic CPU cost growth and potential crashes on Python 3.11+ due to unhandled ValueError exceptions. This affects decoding of untrusted BER/CER/DER inputs in gcalcli versions 4.3.0 up to but not including 4.5.1_13. The issue is fixed in version 4.5.1_13 by limiting tag ID size and improving error handling.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-m4p7-r5rc-7g4j (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59884 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/628e36ecbb5277a3f01572ce418ef54271b165a5 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/pyasn1/PYSEC-2026-3455.yaml (opens in a new tab)