Skip to main content
VulnerabilityPublished Updated

CVE-2026-13346: Pypy3.11 · pip would incorrectly handle doubly-encoded package URLs from indexes

Affects pypy3.11Source GCVE Database

0
Compare
Authoritative record:CVE-2026-13346· Medium 5.6

Not known to be exploited · CVSS 5.6 Medium : upgrade to 7.3.23_2 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.3.23_2
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pypy3.11 to 7.3.23_2.

Affected software

ProductAffectedFixed in
Homebrewpypy3.11pkg:brew/pypy3.11Other threatsAffected
  • >=7.3.23 <7.3.23_2
Fixed in
  • 7.3.23_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

pip would incorrectly handle doubly-encoded package URLs from indexes allowing for files to be installed to arbitrary locations on disk even when installing wheels. This vulnerability requires downloading or installing a package from a malicious package index to succeed, malicious packages alone are not able to exploit this vulnerability. Note that this vulnerability only materially impacts users running `pip download` with the `--only-binary` option as installing source distributions from an untrusted index is already an unsafe operation that executes code during install time.

References

Community reviews

Loading reviews…