Skip to main content
VulnerabilityPublished

CVE-2026-115557: Python · Distrust compromised intermediate certificates in ssl module

Affects pythonSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115557· Critical 9.4

Not known to be exploited · CVSS 9.4 Critical · fixed in 3.15.2 : patch python as a priority.

Data as of 31 Oct 2026, 00:52 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PSF)CVSS 4.09.4
Patch
Available – fixed in 3.15.2, 3.14.10, 3.13.18 +2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Bitnamipythonpkg:bitnami/pythonOther threatsAffected
  • <3.11.18
  • >=3.12.0 <3.12.16
  • >=3.13.0 <3.13.18
  • >=3.14.0 <3.14.10
  • >=3.15.0 <3.15.2
Fixed in
  • 3.11.18
  • 3.12.16
  • 3.13.18
  • 3.14.10
  • 3.15.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to Python versions 3.11.18, 3.12.16, 3.13.18, 3.14.10, or 3.15.2 or later. These versions include the denylist for compromised intermediate certificates, ensuring automatic rejection regardless of SSLContext configuration.

Description

Python's ssl module has been updated to include a denylist of known compromised intermediate certificates. This enhancement ensures that these certificates are automatically rejected, improving security even if certificate revocation is not configured. The vulnerability affects multiple Python versions prior to their respective fixed releases.

References

Community reviews

Loading reviews…