Python git: GitPython from 3.1.30 before 3.2.0 contains a remote code execution vulnerability in Remote.pull() whose
Affects python-gitSource GCVE Database
Not known to be exploited · CVSS 9.2 Critical · fixed in 3.2.0 : patch python-git as a priority.
Data as of 28 Oct 2026, 23:41 UTC
- Patch
- Available – fixed in 3.2.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10python-gitpkg:deb/ubuntu/python-git?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSpython-gitpkg:deb/ubuntu/python-git?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSpython-gitpkg:deb/ubuntu/python-git?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSpython-gitpkg:deb/ubuntu/python-git?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSpython-gitpkg:deb/ubuntu/python-git?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSpython-gitpkg:deb/ubuntu/python-git?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in GitPython version 3.2.0 and later. Users should upgrade to version 3.2.0 or newer to remediate this vulnerability. No vendor advisory content was provided to indicate alternative mitigations or that no action is required.
Description
GitPython versions from 3.1.30 before 3.2.0 contain a remote code execution vulnerability in the Remote.pull() method. The vulnerability arises because the unsafe-option guard only inspects keyword arguments and not positional refspec arguments, allowing attackers controlling the refspec to supply a malicious --upload-pack option. This can lead to execution of arbitrary OS commands as the calling process over local-path or SSH transports. The vulnerability has a high severity with a CVSS score of 8.1.
References
- ubuntu.com/security/CVE-2026-110858 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-110858 (opens in a new tab)
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-f9j4-qggq-h239 (opens in a new tab)
- vulncheck.com/advisories/gitpython-3.1.30-before-3.2.0-command-injection-via-remote-pull-refspec (opens in a new tab)