Skip to main content
CVE-2026-32875VulnerabilityPublished Updated

Python lsp server: UltraJSON has an integer overflow handling large indent leads to buffer overflow or infinite loop

Affects python-lsp-serverSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.14.0_1 soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.14.0_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade python-lsp-server to 1.14.0_1.

Affected software

ProductAffectedFixed in
Homebrewpython-lsp-serverpkg:brew/python-lsp-serverOther threatsAffected
  • >=1.6.0 <1.14.0_1
Fixed in
  • 1.14.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in ujson version 5.12.0 which fixes the integer overflow/underflow issues and caps the indent parameter to 1000. Users of python-lsp-server should upgrade to a version that includes this fixed ujson version (>=1.14.0_1). If upgrading is not possible, users should avoid passing untrusted or large indent values, use fixed or no indentation, and ensure indent is non-negative and below the threshold calculated as 2^31 divided by the maximum recursion depth.

Description

CVE-2026-32875 is a vulnerability in the UltraJSON (ujson) library used by python-lsp-server where integer overflow or underflow in handling the 'indent' parameter during JSON serialization can cause a segmentation fault (crash) or an infinite loop. This occurs when the product of the indent value and the nested depth exceeds the 32-bit integer limit or when a large negative indent is used. The issue can lead to denial of service. The vulnerability affects python-lsp-server versions >=1.6.0 and <1.14.0_1. A patch is available in ujson 5.12.0 that fixes the overflow and caps the indent value.

References

Community reviews

Loading reviews…