CVE-2026-66070: rabbitmq-server vulnerabilities
Affects rabbitmq-serverSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.6 High · fixed in 3.5.7-1ubuntu0.16.04.4+esm3 : patch rabbitmq-server soon.
Data as of 3 Nov 2026, 23:01 UTC
- Patch
- Available – fixed in 3.5.7-1ubuntu0.16.04.4+esm3, 3.6.10-1ubuntu0.5+esm1, 3.8.3-0ubuntu0.3+esm2 +3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available. Users should update RabbitMQ Server to the fixed package versions provided by Ubuntu for their respective LTS release. After updating, a restart of the rabbitmq-server service is required to apply the changes. Refer to the Ubuntu security notice USN-8933-1 for detailed update instructions.
Description
Multiple vulnerabilities were discovered in RabbitMQ Server affecting various Ubuntu LTS releases. These include issues such as improper handling of CORS wildcard origins leading to potential cross-site request forgery, incorrect TLS peer-certificate DN handling causing possible cross-site scripting, denial of service via malformed AMQP arrays and WebSocket frames, insecure credential storage in cookies, and bypasses of TLS client authentication and verification. The vulnerabilities affect Ubuntu 18.04 LTS through 26.04 LTS with fixes available in updated package versions.
References
- ubuntu.com/security/notices/USN-8933-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-66070 (opens in a new tab)
- ubuntu.com/security/CVE-2026-66077 (opens in a new tab)
- ubuntu.com/security/CVE-2026-66079 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67231 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67232 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67235 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67236 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67237 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67238 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67239 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67404 (opens in a new tab)
- ubuntu.com/security/CVE-2026-67409 (opens in a new tab)