Skip to main content
CVE-2026-49951VulnerabilityPublished

RAGFlow before 0.27.0 contains a server-side request forgery vulnerability that allows authenticated attackers to

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-49951· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.27.0 when convenient.

Data as of 6 Nov 2026, 19:05 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.16.3
Patch
Available – fixed in 0.27.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade ragflow to 0.27.0.

Affected software

ProductAffectedFixed in
infiniflowragflowAffected
  • <0.27.0
Fixed in
  • 0.27.0
GitHubragflowpkg:github/ragflowOther threatsAffected
  • <0.27.0
Fixed in
  • 0.27.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in RAGFlow version 0.27.0 and later. Users should upgrade to version 0.27.0 or newer to remediate this vulnerability. No vendor advisory or patch link is provided in the data, but the version boundary indicates the fix is included in 0.27.0. Until upgraded, restrict access to the affected endpoint to trusted users only and validate or sanitize the base_url parameter to prevent SSRF exploitation.

Description

RAGFlow versions before 0.27.0 have a server-side request forgery (SSRF) vulnerability in the set_api_key endpoint. Authenticated attackers can supply an unvalidated base_url to force the server to make requests to arbitrary internal or external endpoints. Exploitation can reveal internal service details, open ports, and configuration fingerprints by leaking raw upstream exception text in responses.

References

Community reviews

Loading reviews…