Skip to main content
CVE-2026-58141VulnerabilityPublished

Dify before 1.15.0 contains a server-side request forgery vulnerability that allows any authenticated console user to

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-58141· High 7.2

Not known to be exploited · CVSS 7.2 High : upgrade to 1.15.0 soon.

Data as of 6 Nov 2026, 19:19 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.2
CNA (VulnCheck)CVSS 3.17.6
Patch
Available – fixed in 1.15.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade dify to 1.15.0.

Affected software

ProductAffectedFixed in
langgeniusdifyAffected
  • >=0.6.0 <1.15.0
Fixed in
  • 1.15.0
GitHubdifypkg:github/difyOther threatsAffected
  • >=0.6.0 <1.15.0
Fixed in
  • 1.15.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Dify version 1.15.0 and later. Users should upgrade to version 1.15.0 or newer to remediate this vulnerability. No other mitigation guidance is provided, and no indication exists that the vulnerability is already mitigated or requires no action.

Description

Dify versions prior to 1.15.0 contain a server-side request forgery (SSRF) vulnerability that allows any authenticated console user to bypass SSRF protections and send arbitrary HTTP requests to internal services and cloud metadata endpoints. This is due to insufficient proxy ACL configuration and lack of destination IP validation in the make_request() helper. Exploitation can lead to unauthorized access to internal components and sensitive data such as AWS IAM credentials.

References

Community reviews

Loading reviews…