Skip to main content
CVE-2025-58364VulnerabilityPublished Updated

Red Hat Security Advisory: cups security update

Affects Red Hat cupsSource GCVE Database

0
Authoritative record:CVE-2025-58364· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade the Red Hat redhat/cups package to 8.10 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.10
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/cups package to 8.10.

Affected software

ProductAffectedFixed in
Red Hatredhat/cupspkg:rpm/redhat/cupsOther threatsAffected
  • <8.10
Fixed in
  • 8.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update that fixes this vulnerability. Users should apply the update as described in the Red Hat advisory RHSA-2025:22063. The update is available for Red Hat Enterprise Linux 8 and its variants. No additional mitigation steps are required beyond applying the official patch.

Description

A null pointer dereference vulnerability exists in the Common UNIX Printing System (CUPS) in the ipp_read_io() function, which can lead to a remote denial of service (DoS). This issue affects Red Hat Enterprise Linux 8 versions prior to 8.10.0. Red Hat has released a security update to address this vulnerability. The severity of this issue is rated as moderate by Red Hat, and no known exploits are reported in the wild.

References

Community reviews

Loading reviews…