Skip to main content
CVE-2024-45490VulnerabilityPublished Updated

SUSE · security update for expat

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-45490· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade SUSE to 2.6.3 as a priority.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.6% chance of exploitation in 30 days – higher than 76% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade libexpat/libexpat to 2.6.3.

Affected software

ProductAffectedFixed in
GitHublibexpat/libexpatpkg:github/libexpat/libexpatOther threatsAffected
  • <2.6.3
Fixed in
  • 2.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates for libexpat addressing these vulnerabilities. Users of Red Hat Enterprise Linux 9 on affected architectures should apply the provided security updates as described in the Red Hat advisory RHSA-2024:6754. No additional mitigation steps are indicated beyond applying the official patches.

Description

Multiple moderate severity security vulnerabilities have been identified in the libexpat XML parsing library used in Red Hat Enterprise Linux 9. These include a negative length parsing vulnerability and integer overflow issues. Security updates addressing these issues are available for various architectures including x86_64, aarch64, s390x, and ppc64le. Users are advised to apply these updates to mitigate the vulnerabilities.

References

Community reviews

Loading reviews…