Skip to main content
CVE-2026-26007VulnerabilityPublished Updated

Red Hat Security Advisory: fence-agents security update

Affects Red Hat azure-cliSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-26007· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in Red Hat package updates : patch Red Hat azure-cli soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.85.0, 50.0.0
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade azure-cli to 2.85.0; cryptography to 50.0.0.

Affected software

ProductAffectedFixed in
Homebrewazure-clipkg:brew/azure-cliOther threatsAffected
  • >=2.0.17 <2.85.0
Fixed in
  • 2.85.0
Homebrewcryptographypkg:brew/cryptographyOther threatsAffected
  • <50.0.0
Fixed in
  • 50.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The fence-agents packages provide a collection of scripts for handling remote power management for cluster devices. They allow failed or unreachable nodes to be forcibly restarted and removed from the cluster. Security Fix(es): * cryptography: cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves (CVE-2026-26007) * pyjwt: PyJWT accepts unknown `crit` header extensions (RFC 7515 ?4.1.11 MUST violation) (CVE-2026-32597) * pyasn1: pyasn1 Vulnerable to Denial of Service via Unbounded Recursion (CVE-2026-30922) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…