Skip to main content
CVE-2026-32597VulnerabilityPublished

Red Hat Security Advisory: python-jwt security update

Affects Red Hat python-jwtSource GCVE Database

0
Compare
Authoritative record:CVE-2026-32597· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat pyjwt to 2.12.0 soon.

Data as of 2 Nov 2026, 20:18 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.12.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade pyjwt to 2.12.0.

Affected software

ProductAffectedFixed in
jpadillapyjwtAffected
  • <2.12.0
Fixed in
  • 2.12.0
PyPIpyjwtpkg:pypi/pyjwtOther threatsAffected
  • <2.12.0
Fixed in
  • 2.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated python-jwt packages for Red Hat Enterprise Linux 8.6 Extended Life Cycle and Advanced Update Support. Users should apply these official updates as described in Red Hat advisory RHSA-2026:93780 and the referenced article https://access.redhat.com/articles/11258 to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the vendor-provided patch.

Description

A security vulnerability (CVE-2026-32597) in the Python JWT library (pyjwt) allows acceptance of unknown 'crit' header extensions, violating RFC 7515 section 4.1.11 requirements. This issue affects certain Red Hat Enterprise Linux 8.6 packages and has been rated with an Important security impact by Red Hat. A security update is available to address this issue.

References

Community reviews

Loading reviews…