SUSE · security update for flatpak
Affects SUSESource GCVE Database
Not known to be exploited · patch available : update SUSE when convenient.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
Exploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/flatpakpkg:rpm/redhat/flatpakOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Patches are available and should be applied to update Flatpak to versions 1.10.9, 1.12.9, 1.14.6, 1.15.8 or later. Additionally, updating xdg-desktop-portal to version 1.18.4 or later mitigates the issue by restricting command creation. Red Hat Enterprise Linux 7 users should apply the security update RHSA-2024:3980 and ensure all prior relevant errata are applied. No further action is required beyond applying these official fixes.
Description
Flatpak versions prior to 1.10.9, 1.12.9, 1.14.6, and 1.15.8 contain a vulnerability that allows a malicious or compromised Flatpak application to execute arbitrary code outside its sandbox. This sandbox escape is due to improper handling of the --command argument in the flatpak run command, which can be exploited via the org.freedesktop.portal.Background.RequestBackground interface. The vulnerability is addressed by changes in how arguments are passed to bubblewrap (bwrap) and mitigated in xdg-desktop-portal 1.18.4 by restricting command creation. Patches are available in the specified fixed versions.
References
- access.redhat.com/errata/RHSA-2024:3980 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2275981 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_3980.json (opens in a new tab)
- ubuntu.com/security/CVE-2024-32462 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-32462 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/18/5 (opens in a new tab)
- github.com/flatpak/flatpak/security/advisories/GHSA-phv6-cpc2-2fgj (opens in a new tab)
- github.com/flatpak/flatpak/commit/72016e3fce8fcbeab707daf4f1a02b931fcc004d (opens in a new tab)
- github.com/flatpak/flatpak/commit/81abe2a37d363f5099c3d0bdcd0caad6efc5bf97 (opens in a new tab)
- github.com/flatpak/flatpak/commit/b7c1a558e58aaeb1d007d29529bbb270dc4ff11e (opens in a new tab)
- github.com/flatpak/flatpak/commit/bbab7ed1e672356d1a78b422462b210e8e875931 (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2024_3959.json (opens in a new tab)
- suse.com/security/cve/CVE-2024-32462/ (opens in a new tab)