Skip to main content
CVE-2026-22853VulnerabilityPublished Updated

SUSE · security update for freerdp

Affects SUSESource GCVE Database

0
Compare

Not known to be exploited : upgrade SUSE to 10.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade SUSE to 10.2.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=10 <10.2
  • SUSE
  • x86_64
  • freerdp-2:3.10.3-5.el10_1.2.x86_64
  • freerdp-devel-2:3.10.3-5.el10_1.2.x86_64
  • freerdp-libs-2:3.10.3-5.el10_1.2.x86_64
Fixed in
  • 10.2

AI-suggested

A patch is available and the vulnerability is fixed in FreeRDP version 3.20.1. Users should update to this version or later. Red Hat and Ubuntu have released updated packages that address this issue; applying these vendor-provided updates will remediate the vulnerability. No additional mitigation steps are required beyond applying the official fixes.

Description

FreeRDP versions prior to 3.20.1 contain a heap buffer overflow vulnerability in the RDPEAR NDR array reader due to lack of bounds checking on the on-wire element count. This flaw allows writing past the allocated heap buffer in the ndr_read_uint8Array function. The vulnerability has a high CVSS score of 9.8 and affects multiple Red Hat Enterprise Linux and Ubuntu package versions. It is fixed in FreeRDP version 3.20.1 and later. No known exploits in the wild have been reported. System updates from Red Hat and Ubuntu provide patches to remediate this issue.

References

Community reviews

Loading reviews…