Skip to main content
CVE-2024-22211VulnerabilityPublished Updated

SUSE freerdp · security update for freerdp

Affects SUSE freerdpSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-22211· Low 3.7

Not known to be exploited · CVSS 3.7 Low : upgrade the Red Hat redhat/freerdp package to 9.5.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/freerdp package to 9.5.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/freerdppkg:rpm/redhat/freerdpOther threatsAffected
  • <9.5.0
Fixed in
  • 9.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Patches are available and should be applied to update FreeRDP to version 9.5.0 or later on SUSE platforms. The vendor advisory from Red Hat confirms that updated packages addressing these vulnerabilities have been released. Users should follow vendor guidance to apply the security update promptly. No additional mitigations are indicated beyond applying the official fixes.

Description

Multiple high severity security vulnerabilities affecting FreeRDP 2.x have been addressed in a security update. These include integer overflows, out-of-bounds reads and writes, and null pointer dereferences in various decompression and image processing functions. The vulnerabilities affect FreeRDP versions prior to 9.5.0 on SUSE platforms. Patches are available to remediate these issues.

References

Community reviews

Loading reviews…