Skip to main content
CVE-2026-22852VulnerabilityPublished Updated

Red Hat Security Advisory: freerdp security update

Affects Red Hat freerdpSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade Red Hat freerdp to 8.4.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Red Hat freerdp to 8.4.1.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=8.4 <8.4.1
Fixed in
  • 8.4.1

AI-suggested

Red Hat has released updated FreeRDP packages as part of the RHSA-2026:10735 advisory to address these vulnerabilities. Users should apply the security update for Red Hat Enterprise Linux 8.4 to remediate these issues. For detailed instructions, refer to the Red Hat advisory at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

Multiple security vulnerabilities have been identified in FreeRDP, a free implementation of the Remote Desktop Protocol (RDP) used by the xfreerdp client. These include heap-use-after-free, heap-buffer-overflow, NULL pointer dereference, denial of service, and arbitrary code execution issues. The vulnerabilities affect Red Hat Enterprise Linux 8.4 versions prior to 8.4.1. Red Hat has issued an important security advisory with updates to address these issues.

References

Community reviews

Loading reviews…